User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Can't update the feed error

Post by prazim » Tue Aug 16, 2005 12:39 pm

I am suddenly getting the error"
can't update the feed
XML parse failed
7:L3/C2
mismatched tag

how do I fix this?
Thanks in advance,
Sue

User avatar
support
Site Admin
Posts: 3065
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Re: Can't update the feed error

Post by support » Tue Aug 16, 2005 1:03 pm

sue wrote:I am suddenly getting the error"
can't update the feed
XML parse failed
7:L3/C2
mismatched tag


You are getting this error because there is an error in the RSS feed. Is the channel coming from a plugin or downloaded directly from the net?

If it's from the net, please post the URL here (or you can validate it yourself here).

If it's from a plugin, open the channel, choose Edit|Show last feed and send us a copy of what you see.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Post by prazim » Tue Aug 16, 2005 1:05 pm

I am using the URL monitor plug in. This is what is revealed in show last feed:
<HEAD>
<META HTTP-EQUIV='Content-Type' CONTENT='text/html; charset=utf-8'>
</HEAD>
<HTML><BODY>
<P>The script caused an error:
<PRE style='margin-left:30px'>
Traceback (most recent call last):
File "<string>", line 94, in ?
File "<string>", line 43, in doUrl
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 76, in urlopen
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 181, in open
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 306, in open_http
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 323, in http_error
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 551, in http_error_default
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 837, in __init__
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 787, in __init__
AttributeError: 'NoneType' object has no attribute 'read'

</PRE>
</BODY></HTML>

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Post by prazim » Tue Aug 16, 2005 1:06 pm

I am using the URL monitor plug in. This is what is revealed in show last feed:
<HEAD>
<META HTTP-EQUIV='Content-Type' CONTENT='text/html; charset=utf-8'>
</HEAD>
<HTML><BODY>
<P>The script caused an error:
<PRE style='margin-left:30px'>
Traceback (most recent call last):
File "<string>", line 94, in ?
File "<string>", line 43, in doUrl
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 76, in urlopen
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 181, in open
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 306, in open_http
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 323, in http_error
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 551, in http_error_default
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 837, in __init__
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 787, in __init__
AttributeError: 'NoneType' object has no attribute 'read'

</PRE>
</BODY></HTML>

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Post by prazim » Tue Aug 16, 2005 1:06 pm

I am using the URL monitor plug in. This is what is revealed in show last feed:
<HEAD>
<META HTTP-EQUIV='Content-Type' CONTENT='text/html; charset=utf-8'>
</HEAD>
<HTML><BODY>
<P>The script caused an error:
<PRE style='margin-left:30px'>
Traceback (most recent call last):
File "<string>", line 94, in ?
File "<string>", line 43, in doUrl
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 76, in urlopen
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 181, in open
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 306, in open_http
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 323, in http_error
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 551, in http_error_default
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 837, in __init__
File "awasuMonitorURLs\buildawasuMonitorURLs\out1.pyz/urllib", line 787, in __init__
AttributeError: 'NoneType' object has no attribute 'read'

</PRE>
</BODY></HTML>

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

this ia nother feed with the same error

Post by prazim » Tue Aug 16, 2005 1:08 pm

<?xml version="1.0" encoding="utf-8" ?>
<rss version="2.0">
<channel>
<generator>Monitor URL(s) for changes and report via RSS, by Allan B. Wilson; abwilson@awasu.com</generator>
<title>! Monitoring Customer URL(s) for Changes</title>
<link> </link>
<description>RSS feed to monitor URLs and notify if changes detected</description>
<item>
<title>http://www.allenpress.com/allen_press/programs/modules/collection.php?params=MiwwMDAwNC4wMDAwMCxjb21tdW5pY2F0aW9uX21vZHVsZSxIZWFkbGluZXMsMQ%253D%253D (Headlines)</title>
<link>http://www.allenpress.com/allen_press/programs/modules/collection.php?params=MiwwMDAwNC4wMDAwMCxjb21tdW5pY2F0aW9uX21vZHVsZSxIZWFkbGluZXMsMQ%253D%253D</link>
<guid isPermaLink="false">http://www.allenpress.com/allen_press/programs/modules/collection.php?params=MiwwMDAwNC4wMDAwMCxjb21tdW5pY2F0aW9uX21vZHVsZSxIZWFkbGluZXMsMQ%253D%253D (477123497)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:03:37.
</pre>]]></description>
</item>
<item>
<title>http://www.cambridge.org/ (Cambridge University Press)</title>
<link>http://www.cambridge.org/</link>
<guid isPermaLink="false">http://www.cambridge.org/ (-848880496)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:03:38.
</pre>]]></description>
</item>
<item>
<title>http://www.ejournalpress.com/ (eJournalPress - Web-based manuscript submission, peer review and document tracking for the scientific publishing community.)</title>
<link>http://www.ejournalpress.com/</link>
<guid isPermaLink="false">http://www.ejournalpress.com/ (-1280862430)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:03:38.
</pre>]]></description>
</item>
<item>
<title>http://www.oup.co.uk/ (Oxford University Press - OUP - UK Official Home Page of Oxford University Press - Oxford Books)</title>
<link>http://www.oup.co.uk/</link>
<guid isPermaLink="false">http://www.oup.co.uk/ (377247477)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:03:38.
</pre>]]></description>
</item>
<item>
<title>http://www.springeronline.com/sgw/cda/frontpage/0,11855,4-109-0-0-0,00.html (Springer - Company News)</title>
<link>http://www.springeronline.com/sgw/cda/frontpage/0,11855,4-109-0-0-0,00.html</link>
<guid isPermaLink="false">http://www.springeronline.com/sgw/cda/frontpage/0,11855,4-109-0-0-0,00.html (-479413541)</guid>
<description><![CDATA[<pre>The site has changed; the most recent changes noted were at the following times:
2005-08-16 08:34:06
2005-08-16 08:28:11
2005-08-15 17:28:47
2005-08-15 16:28:20
2005-08-15 15:27:53
</pre>]]></description>
</item>
<item>
<title>http://www.ir.tfinforma.com/tfi/media/pressreleases/ (T Informa - Press releases)</title>
<link>http://www.ir.tfinforma.com/tfi/media/pressreleases/</link>
<guid isPermaLink="false">http://www.ir.tfinforma.com/tfi/media/pressreleases/ (1300514627)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:03:40.
</pre>]]></description>
</item>
<item>
<title>http://www.bepress.com/index.html (The Berkeley Electronic Press)</title>
<link>http://www.bepress.com/index.html</link>
<guid isPermaLink="false">http://www.bepress.com/index.html (-1630114085)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:03:41.
</pre>]]></description>
</item>
<item>
<title>http://www.ieee.org/portal/site (Welcome to the IEEE)</title>
<link>http://www.ieee.org/portal/site</link>
<guid isPermaLink="false">http://www.ieee.org/portal/site (1718935233)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-16 08:28:15.
</pre>]]></description>
</item>
<item>
<title>http://www.wiley.com/WileyCDA/Section/id-101310.html (
Wiley::Corporate News

)</title>
<link>http://www.wiley.com/WileyCDA/Section/id-101310.html</link>
<guid isPermaLink="false">http://www.wiley.com/WileyCDA/Section/id-101310.html (-2127395414)</guid>
<description><![CDATA[<pre>The site has changed; the most recent changes noted were at the following times:
2005-08-16 08:34:08
2005-08-16 08:28:17
2005-08-15 17:28:49
2005-08-15 16:28:24
2005-08-15 15:27:56
</pre>]]></description>
</item>
</channel>
</rss>

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

yet another last feed

Post by prazim » Tue Aug 16, 2005 1:11 pm

<?xml version="1.0" encoding="utf-8" ?>
<rss version="2.0">
<channel>
<generator>Monitor URL(s) for changes and report via RSS, by Allan B. Wilson; abwilson@awasu.com</generator>
<title>! Monitoring Partner URL(s) for Changes</title>
<link> </link>
<description>RSS feed to monitor URLs and notify if changes detected</description>
<item>
<title>http://www.marklogic.com/company/news.html (Mark Logic News - The industry&s leading XML content server)</title>
<link>http://www.marklogic.com/company/news.html</link>
<guid isPermaLink="false">http://www.marklogic.com/company/news.html (-886974904)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:12:04.
</pre>]]></description>
</item>
<item>
<title>http://dx.sheridan.com/news/main.html (DigitalExpert News)</title>
<link>http://dx.sheridan.com/news/main.html</link>
<guid isPermaLink="false">http://dx.sheridan.com/news/main.html (412738560)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:12:05.
</pre>]]></description>
</item>
<item>
<title>http://www.sheridanpress.com/news-releases.htm (The Sheridan Press)</title>
<link>http://www.sheridanpress.com/news-releases.htm</link>
<guid isPermaLink="false">http://www.sheridanpress.com/news-releases.htm (1714232307)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:15:50.
</pre>]]></description>
</item>
<item>
<title>http://www.adobe.com/aboutadobe/pressroom/main.html (Adobe press room)</title>
<link>http://www.adobe.com/aboutadobe/pressroom/main.html</link>
<guid isPermaLink="false">http://www.adobe.com/aboutadobe/pressroom/main.html (-89617550)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-15 08:25:08.
</pre>]]></description>
</item>
<item>
<title>http://www.spitech.com/SPI/News/news.html (SPI Technologies: The Worlds Largest Independent Content Outsourcing
Provider.)</title>
<link>http://www.spitech.com/SPI/News/news.html</link>
<guid isPermaLink="false">http://www.spitech.com/SPI/News/news.html (1294966300)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:12:06.
</pre>]]></description>
</item>
<item>
<title>http://www.salesforce.com/newsevents/ (CRM News & Events - Customer Relationship Management On-Demand - Salesforce.com
)</title>
<link>http://www.salesforce.com/newsevents/</link>
<guid isPermaLink="false">http://www.salesforce.com/newsevents/ (974895570)</guid>
<description><![CDATA[<pre>No changes to the site have been observed since 2005-08-12 14:12:07.
</pre>]]></description>
</item>
<item>
<title>http://www.rightnow.com/news/ (RightNow CRM Industry News, CRM Software | RightNow Technologies)</title>
<link>http://www.rightnow.com/news/</link>
<guid isPermaLink="false">http://www.rightnow.com/news/ (1399404187)</guid>
<description><![CDATA[<pre>The site has changed; the most recent changes noted were at the following times:
2005-08-16 09:10:34
2005-08-16 08:28:15
2005-08-15 17:28:48
2005-08-15 14:27:31
2005-08-15 13:27:15
</pre>]]></description>
</item>
</channel>
</rss>

User avatar
support
Site Admin
Posts: 3065
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Re: yet another last feed

Post by support » Tue Aug 16, 2005 1:25 pm

These both look like problems in the plugin itself. Allan will be along shortly... :-)

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Post by prazim » Tue Aug 16, 2005 1:27 pm

Thank you,
sue

abwilson
Posts: 247
Joined: Sun Feb 09, 2003 12:36 am
Location: San Francisco, CA -- USA

Post by abwilson » Tue Aug 16, 2005 8:08 pm

I notice that you have an older version of the plug-in -- which also happens to be the one available on awasu.com. I have just uploaded a new version for Taka to publish in its place.

In the meantime, please verify that each of the URLs in your list is valid. I just tested the code and it should be resistant to errors (misspellings, malformed URLs, etc.), but perhaps some unusual character combination is slipping through.

While it's somewhat of a hassle, if that still doesn't help, you can remove one URL at a time to identify the problem one(s).

Sorry for the hassle, but thanks for your feedback. Of course, let me know if the error message changes or anything else goes wrong.

Allan

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Post by prazim » Tue Aug 16, 2005 8:21 pm

thanks Allan. I am just seeing this and already posted another error on the site which I guess you can disregard. How will I know when the plugin has been updated on the site?

thanks,
Sue

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Post by prazim » Tue Aug 16, 2005 8:22 pm

thanks Allan. I am just seeing this and already posted another error on the site which I guess you can disregard. the sites are all valid. this error just started happening.

How will I know when the plugin has been updated on the site?

thanks,
Sue

abwilson
Posts: 247
Joined: Sun Feb 09, 2003 12:36 am
Location: San Francisco, CA -- USA

Post by abwilson » Wed Aug 17, 2005 12:35 am

I sent you a copy of the new version directly. Please let me know if you did not receive it.

Thanks

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Post by prazim » Mon Sep 12, 2005 8:29 pm

Allan,
the problem is continuing. When I choose to update the channel, it is only showing me 4 occurrences of one of the web sites i am monitoring. the others are not appearing. i've tried manually updating the channel but that doesn't appear to be solving the problem.
Thanks!
Sue

abwilson
Posts: 247
Joined: Sun Feb 09, 2003 12:36 am
Location: San Francisco, CA -- USA

Post by abwilson » Mon Sep 12, 2005 11:14 pm

Hi, Sue,

I don't understand what problem(s) you're having. Can you explain in more detail or cut and paste examples of what's not right?

Please also let me know the URLs you're monitoring.

Thanks

Allan

Post Reply

Return to “Awasu - Extensions”