Page 1 of 1

Combine Feeds Plugin Rejects Feeds Awasu Accepts

Posted: Thu Jun 08, 2006 2:41 pm
by kleinfelter
When I put a 'normal' feed into Awasu, Awasu accepts it. When I put the same feed into the Combine Feeds Plugin, I get "Can't determine the feed type."

The URI is
https://deimos.apple.com/WebObjects/Cor ... 2.01770196

This happens on other Stanford podcasts too (itunes.stanford.edu).

I'm running "Version 1.9; 28-Sep-05" of the Combine Feeds Plugin. The Channel Feed box on the error message contains:

Code: Select all

<HEAD>
<META HTTP-EQUIV='Content-Type' CONTENT='text/html; charset=utf-8'>
</HEAD>
<HTML><BODY>
<P>The script caused an error:
<PRE style='margin-left:30px'>
Traceback (most recent call last):
  File "CombineFeeds.py", line 120, in ?
  File "CombineFeeds.py", line 113, in main
  File "asyncHTML.pyo", line 18, in __init__
  File "asyncHTML.pyo", line 64, in __init__
  File "asyncore.pyo", line 308, in connect
  File "<string>", line 1, in connect_ex
socket.gaierror: (11001, 'getaddrinfo failed')

</PRE>
</BODY></HTML>

Re: Combine Feeds Plugin Rejects Feeds Awasu Accepts

Posted: Mon Jun 12, 2006 6:46 pm
by support
"Can't determine the feed type." means that Awasu couldn't figure out if the feed is RSS, RDF or Atom. Which makes sense since it's getting an error message from the plugin, not real feed XML :-)

As to what's causing the plugin to fail, you'll have to wait for Allan (the author of the plugin) to chime in. It looks like a problem retrieving the feed, maybe because it's using SSL... :?:

Posted: Mon Jun 12, 2006 6:52 pm
by abwilson
When I click on the link (in Firefox), I get some message about iTunes -- not RSS as I expect. What should I be seeing?

Thanks

Allan

Posted: Tue Jun 13, 2006 1:37 pm
by kleinfelter
Oops. I pasted in the the feed 'home' and not the 'Feed URL'. The URI should be: https://deimos.apple.com/WebObjects/Cor ... 2.01770196.

When I give *this* URI to Awasu, I get the feed processed as expected. When I give it to the combine-channel plug-in, I get the error. When I open the URI in Firefox, I see what appears to be XML for an RSS feed (at least superficially so).

Thanks for responding!

Posted: Wed Jun 14, 2006 2:30 am
by abwilson
Sigh... Do you have another example? When I enter the URI I get:

Not Found
The requested URL /WebObjects/Core.woa/Feed/itunes.stanford.edu.1770152.01770196. was not found on this server.

Thanks

Allan

Posted: Wed Jun 14, 2006 1:03 pm
by kleinfelter
The trailing period is not a part of the URI. Dunno how to tell the forum software not to include it, so here is the URI on a line all by itself.

https://deimos.apple.com/WebObjects/Cor ... 2.01770196

... and I've just done an "Open New Window" from the preview of this message, and clicking the URI will take you to the site.

Thanks for following up!

Posted: Wed Jun 14, 2006 11:13 pm
by abwilson
Okay, I found and fixed the problem, which was related to the https:// URI scheme; it doesn't handle authentication, but lets the "https://" through okay now.

While I was at it I also included the latest feedparser module, which means the plugin now supports Atom 1.0 feeds too.

Taka can make the new version available to everyone; I can also e-mail you the updated version if you wish (if so, let me know your address at abwilsonATawasuDOTcom).


Allan

Posted: Thu Jun 15, 2006 2:03 pm
by kleinfelter
Thanks! (I'll wait and pick up the new version when it appears on awasu.com.)

Posted: Thu Jun 15, 2006 2:23 pm
by support
CombineFeeds v1.9.1 is now available.