Post Reply
Posts: 113
Joined: Wed Jun 30, 2004 1:59 am

Computer destroying Atom feed of horror

Post by squeg » Fri Feb 17, 2006 7:54 pm

I've tried to subscribe to the feed linked from the above page 3 times. Everything seems fine at first, but as I'd advance through the various wizard dialogs, awasu suddenly goes crazy. CPU cycles ramp up, the same dialog tries to render over and over and over again without success, and my entire computer is brought to its metaphorical knees. I can't even kill the process because task manager and process explorer get sucked into awasu's vortex of doom as soon as you launch them. The only way out is to cut the power. I made sure that I can indeed subscribe to other feeds, and there's nothing else unusual that I can see going on with my machine.

I'm sure the original error lies with the feed, but you may want to look into what kind of error can cripple a system so dramatically. (Of course this will probably be one of those things that can only be reproduced on one computer.)

I went ahead and tried to subscribe with firefox's live bookmark feature, and it worked fine. But I'd rather drop the feed than have to read it that way. :)

User avatar
Site Admin
Posts: 3029
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia

Re: Computer destroying Atom feed of horror

Post by support » Sat Feb 18, 2006 2:57 am

Actually, this is a known issue :oops:

The problem is with the feed. It's Atom but is missing the mandatory version attribute so Awasu rejects it. Because it's invalid, Awasu does auto-discovery on it, finds a feed URL and tries to subscribe to it instead. Except that it's the same URL and so Awasu gets into an infinite loop.

Post Reply

Return to “Awasu - Bug Reports”