Post Reply
User avatar
deltabob
Posts: 29
Joined: Thu Mar 31, 2005 1:42 pm
Location: Fairborn, OH

Error 1: File IO Open Error

Post by deltabob » Sat May 07, 2005 2:22 am

I've been getting this message a lot since updating to the 2.1.2 alpha. Any tips on what might be the problem? I have a set up on two different machines (work and home), and I have been getting the message on both.

I'm running XP Home edition at home and XP Professional at work as my operating system.

I tried adding the DEBUG.ini file with this entry:
DefaultSqliteBusyTimeout=300
as an attempt to resolve the issue.

Sometimes when I manually update the channel, it will go fine, but most of the time, I continue getting the File IO Open Error.

Thanks,
deltabob

User avatar
support
Site Admin
Posts: 3032
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Re: Error 1: File IO Open Error

Post by support » Sat May 07, 2005 2:30 am

This is being caused by updates to the search index. You can temporarily disable these by creating a DEBUG.INI file in your user's home directory that looks like this:

Code: Select all

[Debug]
DisableSearchIndexUpdates=1

This will stop Awasu from updating the search index as new content arrives. It also makes things run a bit faster. If you still need to search, the index can be rebuilt manually (e.g. overnight) by using ArchiveMaintenance.exe.

A switch will be added to the 2.1.2.alpha2 release to let you control this from the UI.

User avatar
deltabob
Posts: 29
Joined: Thu Mar 31, 2005 1:42 pm
Location: Fairborn, OH

Post by deltabob » Sat May 07, 2005 4:35 pm

Thanks! This has taken care of the problem. Thanks for the quick response.

Post Reply

Return to “Awasu - Bug Reports”