Page 1 of 1

FTP Channel Report: Background Job Error

Posted: Thu Feb 02, 2006 11:12 pm
by jonahviakeyboard
I just installed the trial pro edition and am trying to FTP a channel report. I keep getting an error that says 'Background job error: Can't open the remote file [whatever I put in the URL field]'

I think I'm able to connect, because if I put in a bad password, I get a different error about not being able to connect.

In the settings, it asks for 4 fields:


URL is the field that's messing me up, I think. I've tried these and similar combinations of others:

What goes in this field?

I posted this in general instead of bugs because I'm certain this my own shortcoming, not a bug.

Thanks for the help.

Re: FTP Channel Report: Background Job Error

Posted: Fri Feb 03, 2006 2:01 am
by support
If you want to send the the file to you need to set:

server =
url = /foo/bar.html

I'm not sure why there's two fields - it should really just be the one :oops: :wall:

Posted: Fri Feb 03, 2006 2:31 am
by jonahviakeyboard
Thanks for the help - I set it up as you indicated but am still having problems.

Now instead of getting the error immeadiately like before, it takes about 20 seconds and then gives the same error:

Background Job Error Can't open the remote file: /folder/report-name.html

However, this time it creates a file of the correct name in the correct location, but it's empty; 0kb.

I'm also creating the file locally, which works fine. True file size is just over 100k. Any ideas? You've got me on the right track...

Posted: Fri Feb 03, 2006 8:42 am
by support
This is possibly a permissions problem. Try using another FTP client and send the file using the same user name/password and see what happens.

Posted: Fri Feb 03, 2006 7:28 pm
by jonahviakeyboard
Using the same user name and password I'm able to upload the same file to the same directory using WS_FTP, either over writing the 0kb file Awasu made or creating a new file. I was able to do the same thing using Internet Explorer as the FTP client.

Then I checked to see if Awasu would over write the good file with the 0kb version. It did.

Then I tried changing the file permissions to 777, but it still prints the 0kb file and gives the same error. I also tried changing the folder permissions are also 777. No luck.

Posted: Sat Feb 04, 2006 4:03 am
by support
Bugger. I've had this before but I can't remember what the problem was :oops:

I'll take a look at it and see if I can reproduce it.

Posted: Sat Feb 04, 2006 10:39 am
by jonahviakeyboard
Thanks so much for the help as always. This feature is really important to me and if it works smoothly is reason enough to get the pro edition. Please let me know if there's anything else I can do to help diagnose the issue.

Posted: Sun Feb 05, 2006 11:39 am
by support
I've set up an alternative FTP server for you to try. Please send us an email and I'll give you the necessary details.

Posted: Thu Feb 16, 2006 2:39 am
by jonahviakeyboard
For anyone that read this thread, here's an update:

Awasu's support was nothing short of phenomenal. Responses were lucid and timely, despite the fact that we are on opposite sides of the planet. After trying many different approaches, it was determined that the problem was specific to me and my host, not Awasu. Great support!

Posted: Thu Feb 16, 2006 10:11 am
by support
jonahviakeyboard wrote:Awasu's support was nothing short of phenomenal.

Thanks for the kind words. You made the front page! :-)